Nav Module not building the links properly??

Moderator: And_One

toddybob
.
Posts: 34
Joined: Fri Mar 22, 2013 3:09 pm

Nav Module not building the links properly??

Postby toddybob » Thu Jun 13, 2013 4:50 am

site page with ranking default view: http://nationaljuniorhockey.com/test5/i ... ntam-major
Joomleague version: Version 2.0.82.388f3e3



I have a couple of questions..... I have a development site that I am building for a hockey league and I am having issues with the navigation module.

I have a menu item (page) build with various module / position assignments for joomleague (and non joomleague modules). The default menu item type is the rankings view. If expand the navigation icons from the teams on the rankings view....everything works fine. The links build correctly to maintain my menu structure and all of my modules publish correctly.

menu item default view:

Image

However, when I installed and used the navigation module. When I select the same team from the same project from the same division (see image)...the link used is a com_joomleague link. Because of this....the main menu structure is lost and I lose ALL module assignments. I do land on the team info page but it's a (com_joomleague) link rather than the menu structure links and I dont get any of my modules appearing because they are assigned to specific "pages" on the menu. How do I fix this so that the navigation module builds the correct link and doesn't break my site ?????

I've looked at the "custom item id" and thought that I needed to set that to the item id of the menu item that is my default view (the above rankings view)....and that menu item id is 629 but when I set that custom item id to 629.....it doesn't change a thing, the navigation module is still sending the "team info" to a parent com_joomleague link.

Side nav module

Image

Link that the side nav module sends my site to:

Image

User avatar
nzrunner
.
Posts: 90
Joined: Sun Sep 14, 2008 10:04 am
Joomleague version: 2.0.x
Location: Sydney, Australia
Contact:

Re: Nav Module not building the links properly??

Postby nzrunner » Mon Aug 12, 2013 6:21 am

I have a similar issue. Did you find a resolution for this issue?
Joomla: 2.5.28
JoomLeague: 2.93.239
http://www.sydneymastershockey.com.au/competition

toddybob
.
Posts: 34
Joined: Fri Mar 22, 2013 3:09 pm

Re: Nav Module not building the links properly??

Postby toddybob » Tue Aug 20, 2013 11:00 pm

nzrunner wrote:I have a similar issue. Did you find a resolution for this issue?


Not yet....updating to latest version now and going to see if it works.

And_One
Joomleague Project Manager, Donator
Joomleague Project Manager, Donator
Posts: 3609
Joined: Fri Sep 11, 2009 4:00 pm
Joomleague version: 2.0.x
Location: Graz
Contact:

Re: Nav Module not building the links properly??

Postby And_One » Tue Aug 20, 2013 11:02 pm

i assume the problem still exists ... create a bugreport

User avatar
nzrunner
.
Posts: 90
Joined: Sun Sep 14, 2008 10:04 am
Joomleague version: 2.0.x
Location: Sydney, Australia
Contact:

Re: Nav Module not building the links properly??

Postby nzrunner » Tue Aug 19, 2014 3:22 am

I am still having the same issue. Has this been resolved?

I am running the final release of Katrina on Joomla 2.5
Joomla: 2.5.28
JoomLeague: 2.93.239
http://www.sydneymastershockey.com.au/competition


Return to “navigation_menu”

Who is online

Users browsing this forum: No registered users and 0 guests