How to change "utf-8" codification to show special characters -RESOLVED-

General discussion regarding the language files.
eukiseioh
Newbie
Posts: 6
Joined: Sat Apr 07, 2007 12:14 am

How to change "utf-8" codification to show special characters -RESOLVED-

Postby eukiseioh » Sun Feb 03, 2008 2:32 pm

I 'm translating joomleague to Spanish but don't shows the special characters as "ñ". I added to each file .xml in the folder / com_joomleague / frontend_config / spanlish this line: . When i reload the page, still do not appear "tildes" and "ñ" ...
Anyone help me, please?

Sorry for my bad english.
Last edited by eukiseioh on Sun Feb 03, 2008 5:00 pm, edited 1 time in total.

felixsingh
Newbie
Posts: 4
Joined: Fri Feb 01, 2008 11:31 pm

Re: How to change "utf-8" codification to show special characters

Postby felixsingh » Sun Feb 03, 2008 2:52 pm

Change the encoding of the xml files from ansi to utf-8. Open the files in an Editor , like notepad2, select all, cut. Then change encoding to utf. Save. Paste the text in, save again. Upload.  :rolleyes: Do the same with your language files.
Which Joomla Version.? Did you do all steps to make Joomla UTF-8?
Last edited by felixsingh on Sun Feb 03, 2008 2:55 pm, edited 1 time in total.

eukiseioh
Newbie
Posts: 6
Joined: Sat Apr 07, 2007 12:14 am

Re: How to change "utf-8" codification to show special characters

Postby eukiseioh » Sun Feb 03, 2008 3:52 pm

My Joomla Version is 1.5 (Stable) in spanish and work fine with special characters. Only don't work in joomleague extension. I changed the enconding of xml files to UTF-8 (only xml files in /frontend_config/ folder) and don't work. have i to make any change else?

eukiseioh
Newbie
Posts: 6
Joined: Sat Apr 07, 2007 12:14 am

Re: How to change "utf-8" codification to show special characters

Postby eukiseioh » Sun Feb 03, 2008 3:57 pm

I made the changes like the German language file because it uses the UTF-8 codification... but don't work for spanish translation.
Last edited by eukiseioh on Sun Feb 03, 2008 3:59 pm, edited 1 time in total.

eukiseioh
Newbie
Posts: 6
Joined: Sat Apr 07, 2007 12:14 am

How to change "utf-8" codification to show special characters -RESOLVED-

Postby eukiseioh » Sun Feb 03, 2008 4:56 pm

I have resolved the problem. I make this:

Add this code line into xml files from frontend_config/ folder:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>


If the files have this line, change the encoding value to "utf-8".
Save the files with "save as" option, select "utf-8" codification and save the file.

The frontend and backend language files save as "utf-8" codification too.

All work with special characters.

kaito
Newbie
Posts: 1
Joined: Wed Nov 12, 2008 5:42 pm

Re: How to change "utf-8" codification to show special characters -RESOLVED-

Postby kaito » Wed Nov 12, 2008 6:02 pm

I'm using a utf-8 encoded database. I had problems with downloadable ical files i.e. special characters weren't displayed correctly. After some code checking I found

Code: Select all

echo utf8_encode($output);
in /lib/ical.php. The convert function caused this mess, so I replaced it with

Code: Select all

echo $output;
and also added charset type for the header:

Code: Select all

header("Content-Type: text/Calendar; charset=utf-8");


Hope it helps for someone else, too.


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest