Fehler beim Kopieren des Moduls _tab_results

sv90
Newbie
Posts: 6
Joined: Fri Nov 09, 2007 11:36 am

Fehler beim Kopieren des Moduls _tab_results

Postby sv90 » Thu Aug 21, 2008 11:57 am

Beim Versuch das Modul zu kopieren erhalte ich folgende Fehlermeldung:

Fatal error: Cannot redeclare getresults() (previously declared in
/www/htdocs/xxxxxx/joomla/modules/mod_joomleague_tab_results.php:59) in
/www/htdocs/xxxxxx/joomla/modules/mod_joomleague_tab_results.php on line 59

Ich hatte gelesen, dass bei dieser Meldung der Befehl doppelt ausgeführt wird, weiß aber nicht wie man das ändert.

An der Zeile 59 ist mir auch nichts aufgefallen.

function getResults( $project, $round = 0, $division = 0, $ordering="ASC", $unpublished = 0 )

Nicht das ich mich falsch ausdrücke, dass kopieren ging ohne Probleme. Nur beim Veröffentlichen beider Module mit unterschiedl. Projekten kommt diese Meldung.

Vielleicht könnt Ihr mir helfen.
Vielen Dank
Last edited by sv90 on Thu Aug 21, 2008 1:00 pm, edited 1 time in total.

User avatar
johncage
.
Posts: 953
Joined: Fri May 11, 2007 11:49 pm
Location: Somewhere under the rainbow
Contact:

Re: Fehler beim Kopieren des Moduls _tab_results

Postby johncage » Thu Aug 21, 2008 5:08 pm

vor function getR...:
if(!function_exists('getResults')) {

und nach der schliessenden }
noch eine } hinterher...

analog bei printTeam(...

if(!function_exists('printTeam')) {
Look, you've got it all wrong! You don't NEED to follow ME, You don't NEED to follow ANYBODY! You've got to think for your selves! You're ALL individuals!
So keep a clear head and always carry a lightbulb.

sv90
Newbie
Posts: 6
Joined: Fri Nov 09, 2007 11:36 am

Re: Fehler beim Kopieren des Moduls _tab_results

Postby sv90 » Fri Aug 22, 2008 12:17 pm

Geht leider auch nicht oder ich bin zu dumm.

User avatar
Didi279
.
Posts: 22
Joined: Tue Mar 20, 2007 1:14 pm
Contact:

Re: Fehler beim Kopieren des Moduls _tab_results

Postby Didi279 » Mon Aug 25, 2008 7:52 pm

Bekomme die Fehlermeldung nicht nur für Zeile 59 sondern auch für 108

Fatal error: Cannot redeclare getresults() (previously declared in .../modules/mod_joomleague_tab_results.php:59) in .../modules/mod_joomleague_tab_results.php on line 108
- Joomleague installiert unter der Seite:   http://www.scsand-frauen.de Joomleague-Version: 0.93b
- Update: 0.90 -> 0.91 -> 0.92 -> 0.93 -> 0.93b
- eingesetzte Browser: IE 8.0 / Firefox
- bevorzugter Browser:IE 8.0

Tony
.
Posts: 296
Joined: Sun Apr 29, 2007 2:31 pm

Re: Fehler beim Kopieren des Moduls _tab_results

Postby Tony » Tue Aug 26, 2008 8:35 am

Geht leider auch nicht oder ich bin zu dumm.


Glaube ich nicht...  :no:

Im Anhang eine mod_joomleague_tab_results.php, in die die Lösung von johncage bereits
eingebaut ist. Bitte beachten: Version 0.93.  :)

[gelöscht durch Administrator]

sv90
Newbie
Posts: 6
Joined: Fri Nov 09, 2007 11:36 am

Re: Fehler beim Kopieren des Moduls _tab_results

Postby sv90 » Tue Aug 26, 2008 10:21 am

Vielen, vielen Dank, jetzt klappt alles. :thx:

User avatar
Didi279
.
Posts: 22
Joined: Tue Mar 20, 2007 1:14 pm
Contact:

Re: Fehler beim Kopieren des Moduls _tab_results

Postby Didi279 » Tue Aug 26, 2008 4:34 pm

Gute arbeit, passt alles.

Jetzt sollte es nur noch als gelöst markiert werden :cool:
- Joomleague installiert unter der Seite:   http://www.scsand-frauen.de Joomleague-Version: 0.93b
- Update: 0.90 -> 0.91 -> 0.92 -> 0.93 -> 0.93b
- eingesetzte Browser: IE 8.0 / Firefox
- bevorzugter Browser:IE 8.0


Return to “mod_joomleague_tab_results”

Who is online

Users browsing this forum: No registered users and 1 guest

cron