next match modul: logos werden nicht angezeigt

salvi70
Newbie
Posts: 11
Joined: Sun Jul 20, 2008 2:07 pm
Contact:

next match modul: logos werden nicht angezeigt

Postby salvi70 » Mon Jul 21, 2008 3:16 pm

ich habe auf 0.93 umgestellt. soweit so gut.
nun habe ich das next-match-modul installiert und es funktioniert auch bis auf die tatsache, dass die mannschaftslogos nicht angezeigt werden.
und der fehler ist mir auch bekannt:
die mannschaftslogos - z.b. das logo von verona - werden im folgenden ordner gesucht: http://www.rwsoleluna04.ch/images/jooml ... mittel.gif

ich habe die ganze website jedoch nicht auf oberster ebene, sondern in einem unterordner "joomla".
d.h. die logos sind hier: http://www.rwsoleluna04.ch/joomla/image ... mittel.gif

wo kann ich den link im modul nun abändern?

die site:
http://www.rwsoleluna04.ch/joomla

danke!
Last edited by salvi70 on Mon Jul 21, 2008 4:23 pm, edited 1 time in total.

User avatar
axBoe
.
Posts: 129
Joined: Sat Mar 03, 2007 11:11 am
Contact:

Re: next match modul: logos werden nicht angezeigt

Postby axBoe » Mon Jul 21, 2008 4:16 pm

Nur mal eine  Frage: Wäre es nicht wirklich einfacher nur den Ordner "image" (und seine Unterordner natürlich) auf die Root-Ebene zu verschieben? Ist dauerhaft vielleicht einfacher als etwas im Code zu ändern. Mit dem nächsten Update wäre die Arbeit sonst wieder zu erledigen - ich weiß, vielleicht nicht die Antwort, die Du hören wolltest, aber zumindest ein Lösungsweg.
Joomla 1.0.15 - Joomleague 0.92 und
Joomla 1.5.14 - Joomleague 0.93b (legacy)

salvi70
Newbie
Posts: 11
Joined: Sun Jul 20, 2008 2:07 pm
Contact:

Re: next match modul: logos werden nicht angezeigt

Postby salvi70 » Mon Jul 21, 2008 4:23 pm

yup, hab ich mir auch überlegt.

ich habe mich aber nun im code etwas schlau gemacht und selber die lösung gefunden.

in der modul-datai "mod_joomleague_next_match.php" habe ich die zeilen 303 und 304 abgeändert und zwar so:

$matchpart1_pic = (trim($match->home_logo) != "")? sprintf('%s', $match->home_logo, $match->home_name) : "";
    $matchpart2_pic = (trim($match->away_logo) != "")? sprintf('%s', $match->away_logo, $match->away_name) : "";

so klappt es nun :-)

User avatar
Harrie
.
Posts: 333
Joined: Thu Aug 16, 2007 9:55 am
Joomleague version: 2.0.x
Location: The Netherlands
Contact:

Re: next match modul: logos werden nicht angezeigt

Postby Harrie » Wed Jul 30, 2008 10:37 am

Hello,

I have the same problem (see picture) in next match and last match

The pictures for "Spanje" en "Italie" are in the folder:
http://sport-pool/cms/images/joomleague/flags/

The module looks for them in that folder, so this is ok.

The pictures for "NKV 1" en "Klimop 1" are in the folder:
http://sport-pool/cms/images/joomleague/teams/

The module looks for them in the folder http://sport-pool/images/joomleague/teams/ so this is not ok.

How is this possible that for some pictures the subfolder "cms" is used and for other pictures this folder is not used?

[gelöscht durch Administrator]
Using Joomleague since version 0.90
Production: Latest Joomla version, Latest JoomLeague version

User avatar
Harrie
.
Posts: 333
Joined: Thu Aug 16, 2007 9:55 am
Joomleague version: 2.0.x
Location: The Netherlands
Contact:

Re: next match modul: logos werden nicht angezeigt

Postby Harrie » Wed Jul 30, 2008 11:07 am

When selecting images using the dropdownbox, there is an extra "\" added to the location. Removing this "\" does solve the problem.

Where in the code can we solve this bug ??

[gelöscht durch Administrator]
Using Joomleague since version 0.90
Production: Latest Joomla version, Latest JoomLeague version

Tony
.
Posts: 296
Joined: Sun Apr 29, 2007 2:31 pm

Re: next match modul: logos werden nicht angezeigt

Postby Tony » Wed Jul 30, 2008 11:23 pm

In "admin.joomleague.php", line 3221. Get rid of the first forward slash and everything will be fine.  :yes:

Old: $images[] = mosHTML::makeOption( '/images/joomleague/teams/'.$l, $l );

New: $images[] = mosHTML::makeOption('images/joomleague/teams/'.$l, $l );

Many :thx: for your advice.

PS: Fixed in SVN soon.

richy-rich
Newbie
Posts: 1
Joined: Wed Oct 29, 2008 1:02 pm

Re: next match modul: logos werden nicht angezeigt

Postby richy-rich » Wed Oct 29, 2008 1:13 pm

Hallo,

ich habe das gleiche Problem, bei mir will er die Logos nicht anzeigen, ich kann machen was ich will.
Hab PHP5 auf dem Server und nutze die Version 0.93b.

Kann mir einer helfen, zu sehen ist es auf svararat.de/site/

Gruß
Richy-Rich

Saesch85
Newbie
Posts: 10
Joined: Thu Feb 26, 2009 8:56 pm

Re: next match modul: logos werden nicht angezeigt

Postby Saesch85 » Wed Sep 02, 2009 8:42 pm

richy-rich wrote:Hallo,

ich habe das gleiche Problem, bei mir will er die Logos nicht anzeigen, ich kann machen was ich will.
Hab PHP5 auf dem Server und nutze die Version 0.93b.

Kann mir einer helfen, zu sehen ist es auf svararat.de/site/

Gruß
Richy-Rich


Dito! Hab genau das gleiche Problem. Hier gibt es zwar zig Postings mit einem Link zur Lösung, aber die Links funktionieren leider nicht mehr.  :rolleyes:
Kann mir (uns) jemand weiterhelfen?

Schöne Grüße
Sascha

pkempter
Newbie
Posts: 2
Joined: Tue Aug 25, 2009 11:59 am

Re:next match modul: logos werden nicht angezeigt

Postby pkempter » Fri Sep 04, 2009 12:46 pm

Hallo Leute,
leider habe ich auch so ein Problem. :help:
Wenn ich die Startseite meiner Internetseite im IE aufrufe erscheinen keine Logos im next match modul, wenn ich dann auf eine unterseite springe werden die Bilder angezeigt.
Jetzt kommt das komische an der Sache: Im Firefox klappt alles super.
Ich habe auch schon die ganzen Tipps hier ausprobiert und den Pfad für die Logos in einen absoluten Pfad geändert, aber trotzdem keine Logos. Wenn ich aber nur den Pfad der Bilder in den IE kopiere wird mir das Logo angezeigt.

Wenn mir dabei jemand helfen könnte währe das echt super, aber ich komme irgendwie nicht mehr weiter. :thx: :confused:
__________________________________________________
Seite: http://www.fcschwa-wo.de
Jommla 1.0.15
Joomleague 0.93

User avatar
lebleu
.
Posts: 72
Joined: Tue Mar 13, 2007 8:05 am
Contact:

Re:next match modul: logos werden nicht angezeigt

Postby lebleu » Fri Sep 04, 2009 3:45 pm

Ich sehe alles im IE 8.

Ois Isy.
----
Wir sehen uns in der Hölle. - Arthur Spooner
----
www.tsv-strassberg.de Joomleague: 0.93b (mit Zeta) - Joomla: 1.0.15

pkempter
Newbie
Posts: 2
Joined: Tue Aug 25, 2009 11:59 am

Re:next match modul: logos werden nicht angezeigt

Postby pkempter » Sat Sep 05, 2009 11:14 am

Der fehler trat beim IE 7 auf. Aber jetzt habe ich wenigstens eine erklärung, bzw. den fehler gefunden. Ich hatte ein Ajax Pop-Up Modul aktiviert welches mir eine kleine werbung eingeblendet hat. Als ich dieses nun deaktiviert habe hat wieder alles geklappt!
Kann mir zwar auch nicht wirklich erklären wie es dazu gekommen ist, aber ich bin einfach nur glücklich den fehler jetzt beseitigt zu haben.
Aber trotzdem vielen Dank an eure Hilfe, ist ein echt super Forum hier!!! :thx:

delly
Newbie
Posts: 2
Joined: Mon May 24, 2010 12:42 am

Re: next match modul: logos werden nicht angezeigt

Postby delly » Mon May 24, 2010 12:49 am

Für alle die Joomla in einem Unterordner installiert haben

(z.B. root/xy/index.php)
hab hier entwas rumgestöbert und hab das "Icon-Anzeige-Problem" folgend gelöst:

datei: mod_joomleague_next_match.php - ab Zeile 304

Code:

$matchpart1_pic = (trim($match->home_logo) != "")? sprintf('<img src="%s" alt="%s"/>', $match->home_logo, $match->home_name) : "";
$matchpart2_pic = (trim($match->away_logo) != "")? sprintf('<img src="%s" alt="%s"/>', $match->away_logo, $match->away_name) : "";


ändern in:

$matchpart1_pic = (trim($match->home_logo) != "")? sprintf('<img src="'.$mosConfig_live_site.'/'.$match->home_icon.'/%s" alt="%s"/>', $match->home_logo, $match->home_name) : "";

$matchpart2_pic = (trim($match->away_logo) != "")? sprintf('<img src="'.$mosConfig_live_site.'/'.$match->away_icon.'/%s" alt="%s"/>', $match->away_logo, $match->away_name) : "";


so hat es bei mir zumindest funktioniert...

hf & gl
Delly

delly
Newbie
Posts: 2
Joined: Mon May 24, 2010 12:42 am

Re: next match modul: logos werden nicht angezeigt

Postby delly » Mon May 24, 2010 9:49 am

:bash:

so muss natürlich der geänderte Code aussehen:

$matchpart1_pic = (trim($match->home_logo) != "")? sprintf('<img src="'.$mosConfig_live_site.'/'.$match->home_logo.'" alt="%s"/>', $match->home_logo, $match->home_name) : "";

$matchpart2_pic = (trim($match->away_logo) != "")? sprintf('<img src="'.$mosConfig_live_site.'/'.$match->away_logo.'" alt="%s"/>', $match->away_logo, $match->away_name) : "";
}


Sorry! mein Fehler! :whistling:

hermsdorfersv
Newbie
Posts: 2
Joined: Thu Aug 05, 2010 8:34 pm

Re: next match modul: logos werden nicht angezeigt

Postby hermsdorfersv » Thu Aug 05, 2010 10:34 pm

danke delly! hab wochen probiert und gesucht. endlich klappts!! :D


Return to “mod_joomleague_next_match”

Who is online

Users browsing this forum: No registered users and 1 guest

cron