After Update -> strange Date format with "%"-symbols

Moderator: And_One

User avatar
fcbfan
Newbie
Posts: 14
Joined: Fri Jun 29, 2012 1:53 pm
Joomleague version: 2.0.x
Contact:

After Update -> strange Date format with "%"-symbols

Postby fcbfan » Sat Jul 20, 2013 3:01 pm

Hi,

i updated JoomLeague 2 days ago to Version: v2.0.86.435ee1b.

Now all kick-off/match day dates in the result modules look strange with a lot of "%"-Symbols in it (see Picture in the attachment). In normal Result front-end view it looks normal. How do i fix this?

Greetings,

fcbfan
You do not have the required permissions to view the files attached to this post.

Heart
Joomleague Core Developer
Joomleague Core Developer
Posts: 653
Joined: Fri Apr 23, 2010 10:27 am

Re: After Update -> strange Date format with "%"-symbols

Postby Heart » Mon Jul 22, 2013 10:31 am

check your language file. should look like

Code: Select all

MOD_JOOMLEAGUE_RESULTS_DATE_FORMAT="d. M. Y"

(https://gitorious.org/joomleague/joomle ... esults.ini)

User avatar
fcbfan
Newbie
Posts: 14
Joined: Fri Jun 29, 2012 1:53 pm
Joomleague version: 2.0.x
Contact:

Re: After Update -> strange Date format with "%"-symbols

Postby fcbfan » Wed Jul 24, 2013 10:13 pm

Thank you very much for your help. Now, the dates are correct.

The funny thing is, i checked the language file you told me to check and it was correct. I checked the german file too but there was no entry like this. Is that like it should be? I added it myself though but my problem was still there. So i got in the back-end and checked the settings of the result module. Now the funny part: i just deleted the "%" symbols and it showed the dates/time correct. There was only "a" for "year" instead of "Y" and "m" for "minute" instead of "i", so i had to changed that too. But is that correct? I mean, in PHP strftime it says you have to write it with "%" :confused: .

I added two screenshots. One of the setting, which now is working for me and the view of the module in front-end. So if this is not the way it should be plz tell me so i can solve this the right way. But for now it is fine for me ;) .

Settings in Back-End:

date_backend.png


The module on the site:

date_frontend.png
You do not have the required permissions to view the files attached to this post.


Return to “results”

Who is online

Users browsing this forum: No registered users and 1 guest