Migration von 1.6 nach 2.0 -

Moderators: And_One, Heart

User avatar
Dotzi70
Newbie
Posts: 13
Joined: Wed Jun 25, 2008 8:39 am
Joomleague version: 2.0.x
Location: Niederlinxweiler
Contact:

Migration von 1.6 nach 2.0 -

Postby Dotzi70 » Sun Aug 10, 2014 9:41 am

Ich habe über 63 Projekte in Joomleague 1.6 gespeichert, die ich gerne auf Joomleague 2.0 migrieren würde. Dazu habe ich lokal einen Linux Webserver mit Joomla 2.5.24 und Joomleague 2.0 aufgesetzt. Die Tabellen von Joomleague 1.6 habe aus der alten Datenbank exportiert und in die neue Datenbank importiert.

Allerdings gelingt es mir nicht die Daten in die neue Umgebung zu migrieren. Ich führe zuerst das Skript jl_upgrade-1_6_to_2_0.php aus. Egal wie lange ich warte (>20 Minuten), es werden keine Daten migriert. Bei letzten Schritt wird immer angezeigt 0 Records migrated.

Die PHP Einstellungen stehen auf memory_limit 256M, max_execution_time 900. Als PHP Version setze ich Version 5.4.31 und Apache Version 2.2.15 ein. Das gleiche Probleme habe ich auch wenn ich den Vorgang auf einer Entwicklungsseite meines virtuellen Servers probiere.

Ich habe in Joomla die Option Fehler berichten auf Entwicklung gestellt und System debuggen auf Ja. Alles was ich während des Migrationsvorgangs sehen kann ist, das in die Tabelle joomleague_version etwas eingetragen wird, ansonsten scheinen nur normale Abfrage auf die Datenbank zu passieren, ohne dass Änderungen gemacht werden.

Habe ich zuviele Projekte, dass das Skript zu lange braucht, oder warum passiert scheinbar nichts?

User avatar
Dotzi70
Newbie
Posts: 13
Joined: Wed Jun 25, 2008 8:39 am
Joomleague version: 2.0.x
Location: Niederlinxweiler
Contact:

Re: Migration von 1.6 nach 2.0 -

Postby Dotzi70 » Sun Aug 10, 2014 9:47 am

Im Error-Log der Testseite stehen immer wieder die folgenden Fehler bei Ausführung des Migrations-Skripts:

[Sun Aug 10 09:57:38 2014] [error] [client 192.168.127.1] PHP Strict Standards: Declaration of JLParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in /var/www/html/fcntest.test/administrator/components/com_joomleague/helpers/jlparameter.php on line 552, referer: http://www.fcntest.test/administrator/i ... to_2_0.php

[Sun Aug 10 10:40:18 2014] [error] [client 192.168.127.1] PHP Strict Standards: Declaration of JLParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in /var/www/html/fcntest.test/administrator/components/com_joomleague/helpers/jlparameter.php on line 552, referer: http://www.fcntest.test/administrator/i ... te.display

User avatar
Dotzi70
Newbie
Posts: 13
Joined: Wed Jun 25, 2008 8:39 am
Joomleague version: 2.0.x
Location: Niederlinxweiler
Contact:

Re: Migration von 1.6 nach 2.0 -

Postby Dotzi70 » Thu Aug 14, 2014 4:26 pm

:bash: ICH habe wohl etwas auf dem Schlauch gestanden. Nachdem ich den Tabellenpräfix von jos_ auf j25_ geändert habe konnte ich auch alle meine Projekte sehen und bin gerade dabei das Upgrade der Tabellen durchzuführen.


Return to “de-DE”

Who is online

Users browsing this forum: No registered users and 2 guests

cron