Installer reports as Invalid PHP version 5.2.17

Status: Finished
Branch: https://gitlab.com/joomleague/joomleague/tree/master

Moderator: And_One

JuanLUX
Newbie
Posts: 6
Joined: Mon Aug 04, 2008 4:24 pm

Installer reports as Invalid PHP version 5.2.17

Postby JuanLUX » Sun Aug 10, 2014 1:37 am

Fresh Install of Katrin release on a Test Server.
The Installer ends correctly but shows the message:

error1.png


Access to the Component Backend is not posible the following message appears:

error2.png


Of course my PHP versión is newer that 5.2.4. More exactly is: 5.2.17

??????

info.png
You do not have the required permissions to view the files attached to this post.

User avatar
pascalwilikens
Newbie
Posts: 18
Joined: Wed May 12, 2010 7:06 pm
Location: Belgium
Contact:

Re: Installer reports as Invalid PHP version 5.2.17

Postby pascalwilikens » Tue Aug 26, 2014 7:05 pm

Has anybody already a solution for this. I have the same error with a fresh install of Joomla
PHP gebouwd op Linux node1 2.100.4-1-amd64-grsec #1 SMP Tue Dec 28 21:57:50 CET 2010 x86_64
Database versie 5.5.23-MariaDB-mariadb1~squeeze
Database collatie utf8_general_ci
PHP versie 5.2.42-servage30
Webserver Apache
WebServer naar PHP interface apache2handler
Joomla! versie Joomla! 2.5.24 Stable [ Ember ] 25-July-2014 13:00 GMT
Joomla! Platform versie Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
Gebruikersagent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.149 Safari/537.36
and I installed the last joomleague from the site.

When I access the joomleague admin I get
COM_JOOMLEAGUE_INVALID_PHP1
COM_JOOMLEAGUE_INVALID_PHP2

Fatal error: Class 'JLGControllerAdmin' not found in /mounted-storage/home73b/sub001/sc15866-GBWY/vcvisie.be/new/administrator/components/com_joomleague/controller.php on line 24

JuanLUX
Newbie
Posts: 6
Joined: Mon Aug 04, 2008 4:24 pm

Re: Installer reports as Invalid PHP version 5.2.17

Postby JuanLUX » Tue Aug 26, 2014 10:09 pm

Hi,

I have found my own "solution" to this. It seems that minimum requirements for joomleague include PHP 5.3.0 (despiste the wrong message that appears after installation requesting 5.2.4 or above).
It is curious that a component like joomleague have more requirements that the Joomla 2.5 itself

What I have done to bypass the error and, by the moment all works fine for me (I only use the standings and results capabilities of the component) is to edit the components\com_joomleague\joomleague.core.php file and around line 14 change the "5.3.0" string by for instance "5.2.4".

Please be aware that, this change could result on some other errors on other parts of the component that could need specific 5.3.0 PHP code. It would be great if the developers will clarify this; anyway and as I have mentioned before for standings and project results it is working fine for me either at the frontend and backend.

User avatar
pascalwilikens
Newbie
Posts: 18
Joined: Wed May 12, 2010 7:06 pm
Location: Belgium
Contact:

Re: Installer reports as Invalid PHP version 5.2.17

Postby pascalwilikens » Wed Aug 27, 2014 8:04 pm

Thanks this solved the problem for me to

User avatar
comraden
Joomleague Core Developer
Joomleague Core Developer
Posts: 1278
Joined: Thu Aug 16, 2007 2:27 pm
Location: Poland, Lublin
Contact:

Re: Installer reports as Invalid PHP version 5.2.17

Postby comraden » Thu Sep 04, 2014 11:58 am

I got this error on my hosting server too.
@And_One, U changed this line from
"5.2.4"
to
"5.3.0"
about 8 (eight) months ago.
Any special reasons?
Could I revert it back to "5.2.4"?

by the way:
I will try back to developing jl....
http://llk.pl::jl_1.6 | jl_2.x testing/production enviroment
samiec alfa koncernu 'Cham_Burak_Prostak' || proved: the most annoying person on the forum

And_One
Joomleague Project Manager, Donator
Joomleague Project Manager, Donator
Posts: 3609
Joined: Fri Sep 11, 2009 4:00 pm
Joomleague version: 2.0.x
Location: Graz
Contact:

Re: Installer reports as Invalid PHP version 5.2.17

Postby And_One » Thu Sep 04, 2014 12:16 pm

Code: Select all

$end = $start->add(new DateInterval('PT'.$totalMatchDuration.'M'));


DateInterval class (PHP 5 >= 5.3.0)

Heart
Joomleague Core Developer
Joomleague Core Developer
Posts: 653
Joined: Fri Apr 23, 2010 10:27 am

Re: Installer reports as Invalid PHP version 5.2.17

Postby Heart » Thu Sep 04, 2014 12:18 pm

present in these files for example...

Code: Select all

$ grep -irn "DateInterval" *
administrator/components/com_joomleague/helpers/joomleaguehelper.php:719:                       $end = $start->add(new DateInterval('PT'.$totalMatchDuration.'M'));
components/com_joomleague/helpers/html.php:70:                          $endTime->add(new DateInterval('PT'.$totalMatchDuration.'M'));

Heart
Joomleague Core Developer
Joomleague Core Developer
Posts: 653
Joined: Fri Apr 23, 2010 10:27 am

Re: Installer reports as Invalid PHP version 5.2.17

Postby Heart » Thu Sep 04, 2014 12:23 pm

comraden wrote:by the way:
I will try back to developing jl....

:thx:

User avatar
comraden
Joomleague Core Developer
Joomleague Core Developer
Posts: 1278
Joined: Thu Aug 16, 2007 2:27 pm
Location: Poland, Lublin
Contact:

Re: Installer reports as Invalid PHP version 5.2.17

Postby comraden » Thu Sep 04, 2014 12:33 pm

And_One wrote:

Code: Select all

$end = $start->add(new DateInterval('PT'.$totalMatchDuration.'M'));


DateInterval class (PHP 5 >= 5.3.0)

ok
http://llk.pl::jl_1.6 | jl_2.x testing/production enviroment
samiec alfa koncernu 'Cham_Burak_Prostak' || proved: the most annoying person on the forum


Return to “2.93.239.9df0b25-Katrin”

Who is online

Users browsing this forum: No registered users and 3 guests

cron